is NOT opening or reachable

Hello I’ve faced the same issue with Ip recently, so I’d like your advice on how to solve it. Seems like I’ve tried everything there is, nothing has helped yet…

Copy and paste the results of this.

$systemctl status ssh.service
$sudo ufw status
$ip route

I haven’t used the BBB in quite some time, however I do remember it being quite convenient to just use the network connection created by plugging into a USB port. However I do recall it not being very stable. I don’t know if it was a Windows issue or something else. But I quickly realized it was easier and more reliable to connect via Ethernet. Back then, Wifi was a thing, but not nearly as ubiquitous and stable as it is today. So my computer, at the time, had a dedicated Ethernet connection to the Internet. I used another Ethernet adapter and a cross-over cable to the BBB and never had trouble with it again.

However as most people probably use Wifi for accessing the Internet (particularly at home), if your computer/laptop happens to have a built-in Ethernet adapter, you can use that along with an Ethernet cable. And because auto-mode switching is far more common on Ethernet NICs in computers today, you wouldn’t have to use a cross-over cable either. A generic Ethernet cable would likely suffice. If you are working off a laptop that doesn’t have an Ethernet port, then you can get USB-to-Ethernet (or USB-C) dongles off Amazon for quite cheap. Doing a quick search, I think I saw one for less than $13.

I also was using the USB-TTL adapter to access the terminal on BBB directly vs going over ssh. So it was a relatively simple matter of updating the BBB’s Ethernet IP to be compatible with my 2nd NIC without having connectivity already. If you do not have one, I HIGHLY recommend you get one of those if you haven’t already.

And while they do sell cheaper versions on eBay & Amazon, having used both, it is worth getting the genuine FTDI version (search TTL-232R-3V3). At the time, they were selling for ~$25. Although I suspect maybe they’ve come down in price since then? The cables from FTDI look like this:

The cheaper TTL cables are made of much shorter and thinner wire. And while they may use an FTDI chip inside, being shorter can be less convenient, but not nearly as annoying as the thinner wire. Breaking one of the wires off is not difficult to do at all. Although if your only intent and purpose for the cable is to get the BBB setup, and then use ssh from that point on, then the cheaper cable may be just fine. I’d stick with an “Amazon Recommended” cable like this one:
Amazon 6-pin USB-TTL cable

Just looking at the images of this cable, the wires look much thicker than the cheap cable that I got.

Today, I’m using the BBAI64 which doesn’t have the 6-pin header, so I was back to using the USB connection to interact with it early on. But just like before, I found the USB connection to be flaky if left connected for long periods of time. If you only need it for a few hrs, it was fine, but if I left it connected overnight, it not only lost the virtual Ethernet connection, but also tended to mess up other networking aspects of my system forcing a reboot. I got tired of that so I now have my BBAI64 connected to one of my WiFi router’s available Ethernet ports. So now I can access the BBAI64 from any computer in my house. This also has the added benefit of giving the BBAI64 access to the Internet so it can perform apt updates.

So if you can’t get your USB connection to the BB to work at all, it may or may not be the BB’s fault. But to know for sure, you’d need one of those cables to diagnose the problem properly and determine if its a BB issue or a PC issue.

1 Like

Hi I am having same problem. or .2 does not open on browser. Though I am able ping it successfully.

Result of the mentioned commands:

systemctl status ssh.service
ssh.service - OpenBSD Secure Shell server
     Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: e>
     Active: active (running) since Wed 2023-09-06 20:26:32 IST; 47min ago
       Docs: man:sshd(8)
    Process: 913 ExecStartPre=/usr/sbin/sshd -t (code=exited, status=0/SUCCESS)
   Main PID: 944 (sshd)
      Tasks: 1 (limit: 19014)
     Memory: 2.3M
     CGroup: /system.slice/ssh.service
             └─944 sshd: /usr/sbin/sshd -D [listener] 0 of 10-100 startups

Sep 06 20:26:32 marsar-desktop systemd[1]: Starting OpenBSD Secure Shell server>
Sep 06 20:26:32 marsar-desktop sshd[944]: Server listening on port 22.
Sep 06 20:26:32 marsar-desktop sshd[944]: Server listening on :: port 22.
Sep 06 20:26:32 marsar-desktop systemd[1]: Started OpenBSD Secure Shell server.
sudo ufw status

Status: inactive

ip route
default dev eth1 scope link dev wlx5091e3719941 scope link metric 1000 dev docker0 proto kernel scope link src linkdown dev eth1 proto kernel scope link src dev eth1 proto kernel scope link src metric 101 dev eth0 proto kernel scope link src dev eth0 proto kernel scope link src metric 100 dev wlx5091e3719941 proto kernel scope link src metric 600 dev wlx5091e3719941 scope link

Are you able to ssh into the board?
Do you have zenmap or nmap installed on the host, if so scan to see what port is open. You might have append the port number to the URL 192.xxx.x.xxx:3000

FYI, if you are at work and connected to your company network / internet don’t do this, you might get fired so better let your IT or Sys admin know what is going on.

zenmap is .rpm so use alien to convert it to .deb and install it using

$sudo dpkg -i <packagename.deb>

Yes I am able to SSH into the I am on personal network. Appending port 3000 to url was not opening in browser.

I think I figured out the issue. On opening I was getting this page:

On clicking VSCode.html, page won’t load but the port used in URL was 3000.

I was using the latest image from here

Problem was that port 3000 was disabled. It has to be enabled manually(Details)

After running sudo systemctl enable --now bb-code-server, and reloading, I was able to access VSCode.html at port 3000


Let me know if this looks all good to move forward. Thank you :slight_smile:

We don’t use VScode so I would be the wrong person to ask. If you can access it from a browser it would mean your board is configured properly. Are you able to use a standalone web browser and and access the board? If that is the case and it works it would have to be a setup/config issue with VScode.

Vscode, can be a resource hog on am335x, I’m torn between out of the box enabled disabled… I need to better setup the base url, with maybe a readme, I’ve also been thinking of enabling the shellinbox package to easily get to command line thru the browser…

Hi, as shown above in the screenshot, lands to the index/ page. But to access VSCode.html, I have to SSH into the board and only then VSCode Editor loads.

If I SSH into the board and run examples/Beagleboard/Black/seqLEDs.py, I see LEDs blinking in sequence, which means it does communicate correctly.

But, there’s no examples for BeagleBone Blue in the examples folder. Also I feel I think I am missing some other common folders(may be that will show me webpage at instead of directory - index/).

Is this a common problem? In some tutorials I saw Cloud9 IDE making it easier to run commands for sensors directly in the terminal. Can I somehow get Cloud9 like IDE too?

Thanks in advance. Attaching my folder content.

Hi, Not sure if I am following everything correctly, but are you suggesting that cloud9 IDE is right now not supported on latest image for BB-Blue?
Thank you :slight_smile:

Cloud9 (the company) was purchased by Amazon in 2016, all external development really stopped shortly after. I forget which version of nodejs, the whole stack started to break.


Thanks for the context. Is there any new tutorial out there which will help in say interacting with sensors onboard BeagleBone Blue.

Most sensors are just normal linux drivers…

Thank you, I will try to interact with sensors and use BB-Blue for my project.


Do you have a copy of BeagleboneBlack written by D. Malloy. That is the best source for information regarding what you are doing.

1 Like

Thank you, will checkout the book.


Crikey! This post was first published over 3 years ago and nothing has been done to resolve this. This is NOT the quick start user experience I was expecting.

Surely someone would have either fixed this problem or removed it from the core documentation describing the getting started process.

Depends… Linux, Windows, or Mac? Which board, out of box image, newer image?


I’ve literally just opened up my new BeaglePlay box, grabbed the white printed card that’s found inside, typed in the browser “Quick Start Guide — BeagleBoard Documentation” and I’m now blindly following along what’s on that webpage.

It’s not great. TBH.

I at least had a good chuckle when the first thing I’m shown after the “What’s included in the box?” section is the opening sentence “Attaching the antennas can be complicated. This is not the expected BeaglePlay experience and we hope to fix it in the future.”

Really! This must be a first for a quick start guide. Honestly, it’s that bad.

Anyway, I then moved onto the next section “Tethering to PC” where I connected a USB-C cable to my laptop and to my board. Checking my network connections on my LinuxOS laptop (running Ubuntu 22.04) it shows a wired connection was established.

Then I moved onto this next section… “Access VSCode”.

Here the documentation simply says “Once connected, you can browse to [] to access the VSCode IDE to browse documents and start programming your BeaglePlay!”

And this is where I get the “NOT opening or reachable” message.

Out of interest, I tried [] in my browser and this DOES open a page, which provides 2 links, one of which is a html page for VS code but that link fails too (it’s trying to open port 3000).

I then found the forum to search for clues… and found this forum post, which offers plenty of interesting insight, none of which is reflected in the official documentation.

This was probably my fault when getting the final Release to Manufacturing Image to Seeed for Play production…

Since you have the board up, please run “sudo beagle-version” so i can note what we missed in the production image…

For the Play, it’s highly recommend to grab the xfce flasher ARM64 - Debian 11.x (Bullseye) - Monthly Snapshots - 2023-10-07 (also available on Latest Software Images - BeagleBoard )

Should have a few things fixed for the out of box image… Updated Docs PDF (usb flash drive snapshot of: BeagleBoard Documentation — BeagleBoard Documentation ) drive, VSCode enabled on port 3000, working cc1352 BeagleConnect firmware.