[ArduPilot] BeagleBone Blue Unable to Connect for Debian Buster Updates

Hello Beagleboard Community! I am having trouble getting my BeagleBoard Blue to sudo apt-get update or sudo apt -y update

I am currently preparing the board for an Ardupilot installation. (link provided)

Ardupilot X BeagleBoard Blue Tutorial

When running these update commands, I get the following output:


I can ping these packages perfectly fine. I am connected to the internet as well. Any help trying to find the root of the connectivity and timeout issues would be greatly appreciated!!

1 Like

Hello @Redgar ,

There are some newer images available. I found some on this forum. If you look under Bullseye, the kernel standard for those images are 5.10.x, you will find some forum posts for newer images.


P.S. You can now use apt to handle updating/“downgrading” kernels.

@silver2row sorry, but you need to start reading what the user actually posts, instead of just telling them it’s a kernel issue every single time, it’s not helpful…

@Redgar you’re DNS settings have not been properly set, how is your device connected to the internet…

I am not so sure it is DNS, the output above is showing IPV4 addresses, so DNS must be working.

Err1 resolves repos.rcn-ee.com to which is what I get.

I would be more inclined to blame a firewall, especially if going through USB and Windows internet sharing.

Good point, even debian’s server ip’s are correct… Something is blocking traffic on the user’s side.



Okay…no issue. I get what you are saying. I must have misinformed the participant that posted by offering other alternatives instead of knowing exactly what @Redgar means…

All I know, my screen is not big enough to read that output.


P.S. I try w/ ardupilot too and the BBBlue as an autopilot. So, I am sort of aware that things can transpire that are out of control but nothing too in depth as of now since I know nothing about the photo printed output. And sir, no offense. I am not trying to upset you or get you wild w/ passion. I just know w/out seeing the issue, alternative kernels w/ ardupilot is a use and test case.

Some people already know everything in that realm of flying their BBBlue autopilots. I should have known there was something quirky up when updates were not working…?

@Redgar ,

Hello Again…sorry to be wild in thought w/ my presumptions on saying it is a kernel thing when it could very well be something completely different.


Did you ever figure out the cause, sudo dpkg-reconfigure tzdata and put in your actual credentials.

For instance, I am in CDT. So, instead of America, I use US and Central.


P.S. I know that is also a long shot, i.e. as it seems to only work for me. The package tzdata gets updated and upgraded at times and through thoughtful time, I have realized that my package has alterations needing to be made. That command might get you there…

Also… maybe some feedback will help me help you.

uname -a may help resolve conflicts. Anyway, any data you are willing to share may be beneficial to the other two people in this conversation and to me. I use Bullseye w/ arducopter and cross-compiled that sucker! The thing used rsync to upload the binary in 14 seconds flat!

1 Like

Hey so I just tried this. It didn’t seem to make much of a difference! Any other advice? Maybe I should reinstall the OS (not buster but Bullseye?)

Hey! Sorry for the late reply. I sent one 3 hours ago but the discussion approval didn’t go through. So I have Avast Antivirus up. I deactivated those shields. Then I tried again to find that I was still getting those errors. I shut off Windows Firewalls and the installation still fails. I’m not sure what else could block the traffic. Any other advice is greatly appreciated.

Hello @Redgar ,

sudo dpkg-reconfigure tzdata is what command I use to not have to reboot into a “stale” system interface.

It automatically updates the time and zoning which will help to get on a regular time. I am sad to say for now, I do not know the inner workings of the tzdata but I have been lucky w/ it so far.

Another route, outside of what others think and what they can provide by dissecting the issue, is to, yes, reflash the BBBlue.

I sometimes have issues at times w/ updates/upgrades but since updating to current times w/ what is available, image wise here, I have been able to use tzdata to handle my zoning.


P.S. Some people want to be anonymous. I completely understand. Some people dislike the part of debian that tracks, w/ permission of course, crash reports and handles random intake on data to better the system in the long run… I am not that way. I blindly follow until error. Ha. All jokes aside, I think that command may help instead of rebooting into another complete image. But yeppers, Bullseye is an update and a working one in the AutoPilot and ArduPilot world.

I went into ./install-prereqs-ubuntu.sh and looked around. Yep, Bullseye is listed as one of their updatable Distros for ArduPilot.


A couple of things to try.

Are you connecting to the internet by wifi or are you using the USB connection to a Windows (or other OS) computer?

So on the beaglebone, it looks like DNS is fine.
Can you also ping from the beaglebone the IPV4 addresses shown ( & ) ? I am assuming you can or the DNS lookup would be failing.

Assuming you can ping the addresses then something somewhere is blocking access to port 80.

From your computer in a web browser can you access http://repos.rcn-ee.com/ ?

Have you installed a firewall on your beaglebone ?

From a console either as root or using sudo type

iptables -L

If that comes up empty you have no firewall on the beaglebone.

you can also try doing

wget repos.rcn-ee.com

That will try and download index.html from the server (approx 3k)

I expect it will also fail, but worth checking just to rule out something funny with apt.

If you are going via USB then the likely culprit is going to be the computer you are attached to. Especially if you can see the web page on your computer.

If connecting by wifi, then I would look to your access point/router.

Awesome! Could you possibly send a direct link to a distro? I’m very new to this and this forum can help others find a functioning distro!

The Blue also has WiFi, i’d really try connecting to a WiFi access point, before you start trying other images.

I don’t use Windows 10 outside of my corporate required laptop, so sorry, i can’t walk you thru Internet Connect Sharing settings as i don’t use it…


1 Like

Hello @Redgar ,

Like @RobertCNelson stated, WiFi.

If you have not set up WiFi on the BBBlue, you will not get access to the update/upgrade via apt repos.


Hello @RobertCNelson and @silver2row

So my board is connected to the internet. I can ping google.com and get a response. The issue here is getting those updates to not be unreachable as the terminal says.

I may reflash the board with a different Distro as this is Buster and not Bullseye. If you have a link to a more suitable distro, please send it my way! This may be a solution and an issue with the distro.

Always available here…




Thank you for the links. However, as mentioned above, the images need to support Ardupilot. This is key to the project I am building!

One issue at a time…

Personally I’d dump the whole idea of using Windows ICS, just use the built in WiFi and verify your internet works first…

Reading your original post… please share exactly how you physically connected everything and which linux commands you ran. The guide assumes usb0, which if your are also using WiFi world break things…


1 Like

@RobertCNelson ,

Right…some images, the older images, used connmanctl for WiFi access for the BBBlue. Something has changed in the way beagleboard.org handles WiFi, @Redgar .


P.S. Systemd-Networkd is used now. It really depends on your image being used.


I am not using Internet sharing with Windows. I am in fact using the built-in internet with the Beaglebone. I installed Buster, connected the board to my computer via USB, ran the SSH command to connect with it, added the following lines using sudo nano /etc/network/interfaces to establish an IP:

iface usb0 inet static, address, netmask, network, gateway, post-up route add default gw, dns-nameservers

Lastly, I got stuck here after skipping over the tutorial for Linux users

sudo apt -y update, sudo apt install -y locales, sudo dpkg-reconfigure locales

I get the errors at the first line.