Banging my head against WiFi

I have and I also have and I’d trade a kidney to get either of the damn things working.

when i run lsusb they both seem to use the same driver:

root@beaglebone:~# lsusb

Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

my logical device is wlan0. my etc/network/interface lines are:

auto wlan0

allow-hotplug wlan0

iface wlan0 inet dhcp

wpa-ssid [network name here]

wpa-psk [password here]

when i fire it up via ifup or boot, ifconfig reports:

wlan0 Link encap:Ethernet HWaddr 80:1f:02:ee:68:ef

inet addr: Bcast: Mask:

inet6 addr: 2601:8:a580:8d2:821f:2ff:feee:68ef/64 Scope:Global

inet6 addr: fe80::821f:2ff:feee:68ef/64 Scope:Link


RX packets:337 errors:0 dropped:0 overruns:0 frame:0

TX packets:355 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:41326 (40.3 KiB) TX bytes:42056 (41.0 KiB)

which you’d think would be good! my router hands out 10.0.0.* addresses and looks good to me.

usually at this point i can get one or two pings in, maybe 3, but that’s it. i also notice after a reboot i usually can’t get any pings in to the same url, but i can get a ping or two to a different url. then i’m totally fucked.

so, i know i’m getting online fine, i can wget the google homepage and view it successfully, but shortly thereafter i’m done.

i’ve tried adding a bund of other lines to my interface file, such as wireless-rate auto, and wireless-channel 1 (or 11…i have two routers one on channel 1, one on channel 11, but neither works any better.

i tried moving my wpa info to a wpa_supplicant.conf file per other directions, but same result. pretty sure it’s the same thing, just different config files.

this is a brand new beagle bone black i just got from adafruit yesterday. it is running debian 7 wheezy.

totally stumped. :frowning: any help would be immensely appreciated.

here’s the info on one of my routers from iwlist wlan scan:

Cell 02 - Address: 80:EA:96:EE:C9:F0


Frequency:2.462 GHz (Channel 11)

Quality=51/70 Signal level=-59 dBm

Encryption key:on


Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s

24 Mb/s; 36 Mb/s; 54 Mb/s

Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s



Extra: Last beacon: 70ms ago

IE: Unknown: 000E416972706F727445787472656D65

IE: Unknown: 010882848B962430486C

IE: Unknown: 03010B

IE: Unknown: 0706555320010B1E

IE: Unknown: 200100

IE: Unknown: 23021400

IE: Unknown: 2A0100

IE: IEEE 802.11i/WPA2 Version 1

Group Cipher : CCMP

Pairwise Ciphers (1) : CCMP

Authentication Suites (1) : PSK

IE: Unknown: 32040C121860

IE: Unknown: 2D1AAD1917FFFFFF0000000000000000000000000000000000000000

IE: Unknown: 3D160B081100000000000000000000000000000000000000

IE: Unknown: 7F080000000000000040

IE: Unknown: DD0B0017F20100010100000007

IE: Unknown: DD0700039301780320

IE: Unknown: DD0E0017F2070001010680EA96EEC9F1

IE: Unknown: DD090010180200001C0000

IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

IE: Unknown: 46050200010000

here’s the alternative wpa_supplicant.conf setup i’ve also tried, but works no better.

allow-hotplug ra0
iface ra0 inet manual
  wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

then in /etc/wpa_supplicant/wpa_supplicant.conf :

if i ping for a long time, here’s my ridiculously sad stats:

214 packets transmitted, 44 received, +12 errors, 79% packet loss, time 1055425ms

rtt min/avg/max/mdev = 52.923/11248.510/25100.876/6695.707 ms, pipe 19

hopefully this goes without saying, but normally on my own machine i get much much better results.

Just a thought, but changing the foreground and background colors the way you’re doing is terribly distracting. As it is I can not even read the text as it screws with my eyes.

I have and I also have and I’d trade a kidney to get either of the damn things working.

Add a short USB cable between the WiFi adapter and the BBB and see if that works better for you.


My guess is its power related.

It could possibly be power related but I do not think so. What John said is a known issue, and makes sense in the context of 73% packet loss.

Well one of the sites the OP links to what he bought, states power is a known issue hence my comment. Its actually in bold. Also power is pretty common in regards to dropped packets as well.

Because of the high power required by WiFi, a to power both the Bone and WiFi. Flaky behavior and crashes may result if this is not followed! We have a ! The latest Wheezy distributions support this module out-of-the-box. Also, the has support built in. You may find that you need to have a powered hub to use this adapter, so if you’re having power flakiness with your Pi, try a hub! The other is also stated as “requiring high power” from a quick google search as well.

I’m using the recommended power cable from adafruit that supplies a consistent 2amps at 5v…

I’ll try a dongle but that is a real problem for me because I’m trying to make a portable controller with the battery cape so the wifi dongle needs to be minimum. Are there any usb miniature connectors known to work without a dongle? I’d be happy to buy and try another…

Again thanks for all the help!

As a quick test, as we've had a lot of changes since the official
debian image came out:

cd /opt/scripts/tools/
git pull
sudo ./

(sudo reboot)


Justine, well it is a known issue discussed a few times on these forums. If you search these group thoroughly, you’ll find Robert Nelson talking about which devices work the best on Linux, and I do believe he even mentions some that do not require dongles.

This is why I have a problem with adafruit’s stuff. Realtek networking devices have been known to be flaky in Linux for years, yet this is what adafruit sells ? Atheros devices I think is what Robert says works best in Linux on ARM, but feel free to double check yourself.

Just want to thank everyone here for their help, and offer a followup with my discovered solution in case anybody else will find it useful.

I tried 4 different wifi adapters, including Edimax, the one from Adafruit, and D-Link Wireless N150. The Edimax and Adafruit ones were identified by the operating system but never worked consistently. The D-Link Wireless N150 was not even recognized.

Here’s the winner:

My Debian 7 Wheezy Beaglebone Black from Adafruit RevC recognized this KEEBOX without any drivers or modifications needed. I just needed a few lines in /etc/network/interfaces which look like this:

auto wlan0

allow-hotplug wlan0

iface wlan0 inet dhcp



this is all that’s needed for my generic comcast router. best of luck and happy hacking!

welp i take it back. that worked until i restarted, now it doesn’t recognize it at all anymore. funny. linux may be free. but if i value my time at all, it’s cost me so much more than windows or mac ever will, heh.

Or maybe just PEBKAC ?

yep linux people have been telling me it’s been PEBKAC since i first installed it in 1997. finally abandoned it when osx came out. only came back because i want to use these tiny boards but now i recall why i hated it in the first place.

that’s a pretty shitty response, but it’s par for the course in the linux community i suppose. while i haven’t used linux on my own machine in over a decade i’ve worked on it extensively in my jobs as a software engineer, most recently at Facebook. i don’t think, reasonably speaking, the problem is PEBKAC.

where is there any guide of any sort on how to set up wifi on a beagle bone black? i’ll install any distro, new or old, and i’ll use any wifi dongle that is reasonably small. i’ll buy it if i don’t have it. just anything that starts from scratch and actually consistently works. not “well try this if this doesn’t work. try updating the kernel. try this config file.” endless sysadmin shit and all guesses. there should be a consistent, from scratch, guide to doing this. if i can eventually find a reproducible approach i’ll write it up myself.

Well, replace "allow-hotplug" with "auto" and it should work on reboot..