BeagleBone Black doesn't sometimes start. Only Power LED is on

Hi guys,

we have a problem with our Beagle Bone Black (A5C). We are using Ubuntu Raring 13.04 armhf v3.8.13-bone21 (2013-06-14) on the eMMC (no SD Card). The Beagle Bone is placed in a case and we have connected it to a DC power supply. Sometimes (I would say every 5 to 10 times), when we are plugging in our power supply, the BeagleBone powers on (Power LED is on), but nothing more happens (none of the other four LEDs is on). If we are now removing the power supply and putting it in again, the BBB starts normally. I guess the power supply is strong enough: 5A@5V.

Thanks for your help in advance.


I have no idea what is going on inside the box. Most likely you power supply has a ramp up that is too slow. There is more to a power supply than just voltage and current. It may even have a minimum current rating. I have no way to know.



I have experienced this myself too. Not sure what is happening when this occurs, but usually pulling the power ( I power via a USB 3.0 port ) then reapplying fixes it.

Basically, I have given in to that this is just a quirk that occasionally rears it’s head… In the long run if I felt it important to fix, I would probably use some sort of an UPS to solve the issue ( or just power the board via a battery ).

Check the rise time on the power supply. Also, when it hangs, can you check the SYS_REST line?


I can try.

Mostly when I have experienced this, it is when I have made changes to uEnv.txt. I am not sure if there is any correlation, but there you have it.

FWIW, lately, when issuing shutdown now -r , I have not experienced any problems. I am running Debian/Linux (RCN’s build from source instructions / scripts ). and . . .

root@arm:~# uname -a
Linux arm 3.8.13-bone21 #1 SMP Sat Jun 15 19:36:33 MST 2013 armv7l GNU/Linux

Not sure if that has, or could have anything to do with it. but there we have it.

it happens to me too
i was wondering if the reset cap needed to be a bit larger .01uF is
rather small

Reset is controlled by the TPS65217C on power up. The SYS_RESET is just a warm reset, used after the board is up and running. It has an internal debounce circuit in the processor…


I have found that both BBB and BBB seem to be rather sensitive to the rise time of the DC power supply. I did some tests with a controlled rate power circuit and found that if the rise time was greater than around 500uS, then certain of our boards would not start. My solution was to hold reset until the power was stable, then release it. Now we get 100% success. I thought the PMIC chip was designed to be tolerant to slowly rising power, but I have not had time to investigate further.



This is what I mentioned earlier. This was one of the reasons I added the power button. Using that to turn on and off helps this issue. The SW handles it OK, but it takes a little too long to shut down.


for an embedded device that does not have the reset button visable
this poses an issue, is there something that can be done in hardware to
hold the reset low longer ?

The PORz, PMIC_PGOOD, is programmable via a register setting in the TPS65217C.

Get the right power supply, and the issue should not exist.


I thought i read this somewhere a few months ago from tps65217c datasheet

Although the user can modify the power-up and power-down sequence
through the SEQx
registers, those registers are reset to default values when the device
enters SLEEP, OFF
or RESET state. In practice this means that the power-up sequence is
fixed and a otherthan-
default power-down sequence has to be written every time the device is
powered up.
Custom power-up/down sequences can be checked out in ACTIVE mode (PWR_EN pin
high) by using the SEQUP and SEQDWN bits. To change the power-up default
please contact the factory.

so it seems that a very fast ramp up power supply is the only way to
ensure perfect power on
every time since the programming does not hold thru a power cycle
but brownouts and power fluctuations cannot be ruled out even with a top
of the line power supply
seems the only way to really ensure is with a battery connected to the
BBB as well

Which power supply is the right one?

I have four boards and three different power supplies. Three of the boards always boot, on any of those supplies, when the AC is turned on or when the power connector is plugged in. The fourth board never does with any of the power supplies.

The fourth board will boot 100% of the time if the reset button is pushed after it has failed to boot on power up. When I connected the serial cable to see if I could find out what it was doing when it didn't boot I also discovered it would boot 100% of the time when powered up with the serial cable connected. When the serial cable is disconnected it stops booting.

I run NetBSD from an SD card currently, the original Linux is still on the internal flash. It doesn't boot on power up with the SD card plugged in and it doesn't boot with it taken out. The other three boards always do.

The three supplies I've got are a 2A wall wart from either Newark or Adafruit which was recommended for the BBB, a 5A supply with 4 USB outputs and an old HP bench supply. It behaves the same with all of them.

I need the cards to recover from power failures on their own so it's a concern. It certainly seems that not all BBB cards are created equal. If there's a particular power supply that fixes all problems, however, I'd be interested in knowing which.

Dennis Ferguson

Hi Dave,

we have also tried to hold the reset for some time, but unfortunately that didn’t work for us. Although it’s getting better, we don’t have a 100% success rate. How long do you hold the BBB in reset?


Did you check the Wiki? We have power supplies listed there under accessories. Just because a distributor recommends it, does not make it so.

Again, it is not an amperage question.


Well actually we tried it using a transistor for switching on and also using it with just a USB cable. This failure happens again every 10th try.


Are you doing a shutdown of the Kernel or just pulling power? What happens if you use the power button?


One more thing. What are you getting on the serial port, if anything, during the failed power up?


We have tried it with both Kernel shutdown and pulling power. I’m logging the serial debug port and will sent you this log as soon as a failure apperars.


Shutdown does not remove the power, so that may indicate it is not an actual power up issue of the PMIC, as in this case, it is already powered up.