Has Ti dropped support for BeagleBone Black in Yocto

I have gone back to Dunfell and the meta-ti recipe no longer works. It is only for the later version and bitbake will not start (git checkout dunfell in that too). Using main branch of poky it will build an image but that breaks during boot (FDT_ERR_NOTFOUND).
Any suggestions on this?

FYI, you can build an QEMU version just not an image for the target board.

I’m not familiar with the various generations of BBB. I know there were differences, but I don’t know how they related to code and filesystem builds. And likely due to that unfamiliarity, I don’t know what Dunfell QEMU refer to.

Can you explain that (I’m just curious).

That is an older branch of Yocto.
qemu is a machine emulator.


TI doesn’t support the reference Poky distribution of the Yocto Project. Instead, they maintain a different reference distribution called Arago. I have found building Poky for the BeagleBone Black results in a very minimal image. The Arago project should be a better starting point.

Thank you for sharing that, I was beginning to feel that I was just wasting time with yocto. Sadly, I was going by Molloy’s book, page 336 ++ and that did not work.

Did manage to get it to build an image in Dunfell, and that one does not boot either. Its looking for PXE boot so more than likely it is doing that since it cannot find the Flattened Device Tree.

I know what you mean. Half of the projects I attempt lately seem to stall out on outdated information or broken functionality!

I haven’t tried dunfell, but I have built yocto’s kirkstone release for the BBB. I wrote a blog post about it that I will link below. Maybe there’s some information in my process that can help explain the issue you are seeing?

Best of luck!

1 Like

I did get Dunfell image to boot then seen it was on kernel 4.x.
After doing that and all the time spent getting that to work it was time lost.

$sudo rm -r poky

Many years ago they must have gotten off course and forgot that others need to understand how to use it. Conceptually, it seems like the perfect solution, however it reminds be of a huge pile of string laying on the ground.

Yes, that has been a problem for many years. Typically if the website is monetized just move on. Look for a site that is NOT monetized and it will have high value information. What happens is one or many others copy the same nonsense, reformat the layout and create click-bait.

Many of the books especially those from packt are just loaded with “typo errors” and stuff that does not work, seems like nothing has been verified in their offerings.

Derek Molloy’s book is one of the best for getting it correct, seems like he is for real and not cutting and pasting from the internet. Only problems are due to being outdated. The section on poky is most certainly broken and should be removed or updated.

Just looked at your work on poky, looks good.
I added meta-ti, meta-arm, meta-ti-toolchain to the bblayers.conf and in local.conf added dropbear and ??. Ran into problems with the ti stuff, it did build without it.

I have to admit I do not like Yocto at all. Mind you I have not tried building anything with it for a few years now. The last time I tried to build it, for an IMX6UL SBC it refused to build because my system locale was not en-us, but en-gb. At that point I downloaded Buildroot and had a working system in a couple of hours.

Not had any reason to use Buildroot recently either as the default images on my BBx hardware are fine. However if I needed to build a fixed image for a BBB I would probably go with Buildroot over Yocto, but that is more to do with familiarity than any other reason and I like the build environment, no messing around with config files.

1 Like

It’s good to know I’m not the only one that finds Yocto difficult to work with.

Back when we started using the AM335x in our product, we based a lot of it off of Arago and since it built with Yocto, we continue to use it. But I think the people maintaining the various packages haven’t really fully understood how to declare new additions correctly. One of the problems that has always plagued our setup is if the Yocto build fails, just try again and keep trying it and see does it get further, and if it does, keep restarting it until it either errors in the same place over and over OR finishes successfully.

I’ve long suspected dependency-declaration hasn’t been setup correctly and things with dependencies are trying to build before their dependents have. And since the build does tend to be multi-threaded, eventually the various dependencies get built which allows things that were failing to eventually succeed.

Now this may have been a problem that someone within our company created? I don’t know. I just can’t imagine that we’ve customized the build SO much that this would be the case. Most of what we’ve done is removed things from Arago that we knew we didn’t need. We have added a few things in, but I don’t recall that the places where the build would fail were on “our” additions. Hopefully if this was a problem in the early days (2010-2015 era) that these issues no longer exist. Fortunately I no longer have to work with things at that level anymore. But I do recall when I did occasionally have to make bitbake recipe changes, it was never a smooth experience.

Whatever successor we choose to replace AM335x (assuming TI discontinues it), I’ll keep in mind that there are other options to choose from other than Yocto. Although if its not me tasked to perform this investigation, I’m sure they’ll take the path of least resistance and do whatever the vendor did.

The only time I have found Yocto to work is if you are happy with the vendors default BSP. Once you need to make changes, thats where the problems start for me.

I needed to build an image that would fit into 60M, which given the required libraries was perfectly doable. However the vendors minimal build was way to big, and then trying to remove packages that were not required often led to build failures. It got very frustrating very quickly.

Buildroot by default starts with a basic busybox environment, very small footprint.
Adding stuff after that is much easier I think, than trying to remove stuff.

Plus no messing around with recipes, (unless you need to build a custom package)
just run make menuconfig and select the required stuff and build.

There are pros and cons to both of course.

Just found out why that is so.

Should have done my due diligence before trying to work with the project… Just found this while looking for contact information that is not available.

Sorry out and about for a few days… I see no one asked, this… Please post your serial boot log, smells like a missing dtb or you added an overlay that the yocto tree doesn’t support…


That is what I have decided too. Thank you very much for responding. All the yocto stuff has been deleted, don’t see us moving in that direction again.

Hi guys, I’m a bit late to this thread, but I started a project that is using a Beagle Bone Black also, the client is developing to the Sitara chipset. I happen to have done a couple projects on the BBB and had just set one up with a yocto build.

I’m having a problem where the SD image I write (.wic) is on the SD but for some reason my BBB doesn’t want to boot from it anymore, and if I go through holding down switch 2 it writes from my NAND to the SD, best I can tell.

I am building a target dev SDK environment and had it booting from the SD, it was booting the XFCE in X off the HDMI, but now I can’t get it to boot from the SD anymore and will only run if I write over which now I understand must come from my NAND.

I’m using balena etcher to write the SD using the .wic

I checked to see and the boot flag is set to that partition, and it’s the only partition on the rootfs partition. There is a boot partition also.

Any thoughts that might help me boot my yocto SD again? (and boot X)

Do you have a connection to the debug port and see what is going on. That is the only way you will make progress with this.

Yes, I do. I have both the serial/TTL and the miniUSB->USB serial.

I found something out last night. I have been going through the info to what I thought was flashing the NAND, but it seems that it flashes my SD card. I have a build that I burn the .wic file, and all the Qt5 libs, sodium, zeromq that I placed on the image are there and located in /usr/lib/ from that partition.

After I hold down switch 2 and go through the flash, it reboots and requires the SD inserted to boot, but it is a different image, I think the one I grabbed for 4gb. After there are non of the packages are desktop I put on it and it doesn’t boot X11 like it did with XFCE previously.

I was thinking maybe I can just erase the mmcblk when it is boot, I’m not sure if that would force it to boot from the SD I burned??? For the past few days I have been thinking that the libs are in my rootfs on my host dev, and not being located properly the .wic, but as it turns out it seems it keeps flashing my SD and overwriting it with whatever is in it’s NAND. Does that make sense?

Much of the info online for the BBB is so old that nothing holds true. I used this BBB with Angstrom to do a project 10 years ago. I need this BBB to prototype this before the physical device arrives. Any help will be appreciated.


HIGHLY recommend Exploring Beaglebone, Derek Molloy.
Molloy and his colleagues have put together one the most accurate books. Only issue I have found is some stuff like yocto is very dated. Other than that its pretty much a go-to book.

I would try burning the official release on SD and see how that boots. Then compare your code with one that is known working. If the SD has some serious age on it maybe get a different one. Some of those cards just will not run fast enough for booting an ARM board.

Another possible sleeper issue is the power supply that cannot respond fast enough thus putting a glitch on board. That did happen to me and also had a “lab” grade supply start to fold back way before the preset current limit. Rather embarrassing for me…

@foxsquirrel I found out pretty quickly that there is not much that can be done in the shell on the TTL. Unknowing to me, if you just hit a key you get a root prompt, but nothing is mounted and it’s very limited. I mentioned to my client that I thought I might be able to go in and use dd to clear the mmcblk0 which is where the boot mounts from. Back when I used Angstrom n the BBB one needed to assemble the SD themselves by formatting a small partition 50mb at the start for the MLO and kernel. So I like the WIC in that regard, just that I haven’t figured out how to make the partitions do what I want exactly, I probably need to add something to local.conf for my image.

Do you know if I need to short two pins on either of the headers to get it to boot from SD ???

I don’t need the BBB long term, and not looking for any TI support or anything like that, was just trying to get this going on the Sitara as I am not sure there is any other design, and the BBB is an open design, I like it way better than the PIs. Broadcom is only helpful if you buy chips from them, either open/closed. As you might guess, I’m often on the open side. :wink:

Currently I’m using poky and adding meta-qt5 from github and meta-openembedded from github. I am kinda on my own OS wise as I don’t have a hardware vendor to leverage, such as NXP or Xilinx. I used a zedboard and/or minized once for FPGA. My point is I had to clone a couple meta-layers to add into my bitbake recipe which included cloning a couple meta-layers to get a successful image that would boot on the BBB. I pulled meta-qt5 and meta-openembedded as I mentioned. My Qt5 shows as 5.15.7 so that is good and the versions of sodium and zeromq look good. I just need my BBB to boot from the SD.


Hard to argue that statement, but the beaglebone is 10-12 years old at this point, and it was one of the few to be a true open design, in the sense that they provided all the schematics. I am not a hardware engineers, but that is a huge piece that normally vendors like NXP, Xilinx, Wind river, held the companies hostage with royalties.

I also find that a lot of people are still using beaglebones today and the updates are being made to fix bugs that are found, or something that is outdated.

Yes, but one needs to understand the differences between the init, where busybox creates a lightweight set of OS functions, that don’t have all the features. I’ve always thought that quite clever, how Perens created busybox to boot the Debian install from floppies back in the day. But in SysV type inits, you have the various runlevels, 0-6 and can call them pretty much at any point. The small init of busybox avoid that as it carries so much baggage.

The latest yoctoproject does support images that have both styles, but core-image-minimal is not one of them.

I have never found yocto easy to work with, I like to describe it as an onion with layers upon layers of recipes that intertwine with each other. It is so complicated that there is really not a good set of documentation that seems to stay current.

Welcome to the Internet I 'spose…


Here’s the TTL output:
----------------- TTL output -----------------

U-Boot 2019.04-00002-g07d5700e21 (Mar 06 2020 - 11:24:55 -0600), Build: jenkins-github_Bootloader-Builder-137

CPU  : AM335X-GP rev 2.1
I2C:   ready
DRAM:  512 MiB
No match for driver 'omap_hsmmc'
No match for driver 'omap_hsmmc'
Some drivers were not found
Reset Source: Power-on reset has occurred.
RTC 32KCLK Source: External.
Loading Environment from EXT4... Card did not respond to voltage select!
Board: BeagleBone Black
<ethaddr> not set. Validating first E-fuse MAC
BeagleBone Black:
BeagleBone: cape eeprom: i2c_probe: 0x54:
BeagleBone: cape eeprom: i2c_probe: 0x55:
BeagleBone: cape eeprom: i2c_probe: 0x56:
BeagleBone: cape eeprom: i2c_probe: 0x57:
Net:   eth0: MII MODE
cpsw, usb_ether
Press SPACE to abort autoboot in 0 seconds
board_name=[A335BNLT] ...
board_rev=[000C] ...
Card did not respond to voltage select!
Card did not respond to voltage select!
Card did not respond to voltage select!
gpio: pin 56 (gpio 56) value is 0
gpio: pin 55 (gpio 55) value is 0
gpio: pin 54 (gpio 54) value is 0
gpio: pin 53 (gpio 53) value is 1
Card did not respond to voltage select!
Card did not respond to voltage select!
switch to partitions #0, OK
mmc1(part 0) is current device
Scanning mmc 1:1...
gpio: pin 56 (gpio 56) value is 0
gpio: pin 55 (gpio 55) value is 0
gpio: pin 54 (gpio 54) value is 0
gpio: pin 53 (gpio 53) value is 1
switch to partitions #0, OK
mmc1(part 0) is current device
gpio: pin 54 (gpio 54) value is 1
Checking for: /uEnv.txt ...
Checking for: /boot.scr ...
Checking for: /boot/boot.scr ...
Checking for: /boot/uEnv.txt ...
gpio: pin 55 (gpio 55) value is 1
2004 bytes read in 14 ms (139.6 KiB/s)
Loaded environment from /boot/uEnv.txt
Checking if uname_r is set in /boot/uEnv.txt...
gpio: pin 56 (gpio 56) value is 1
Running uname_boot ...
loading /boot/vmlinuz-4.19.94-ti-r42 ...
10095592 bytes read in 654 ms (14.7 MiB/s)
debug: [enable_uboot_overlays=1] ...
debug: [enable_uboot_cape_universal=1] ...
debug: [uboot_base_dtb_univ=am335x-boneblack-uboot-univ.dtb] ...
uboot_overlays: [uboot_base_dtb=am335x-boneblack-uboot-univ.dtb] ...
uboot_overlays: Switching too: dtb=am335x-boneblack-uboot-univ.dtb ...
loading /boot/dtbs/4.19.94-ti-r42/am335x-boneblack-uboot-univ.dtb ...
162266 bytes read in 44 ms (3.5 MiB/s)
uboot_overlays: [fdt_buffer=0x60000] ...
uboot_overlays: loading /lib/firmware/BB-ADC-00A0.dtbo ...
867 bytes read in 301 ms (2 KiB/s)
uboot_overlays: loading /lib/firmware/BB-BONE-eMMC1-01-00A0.dtbo ...
1584 bytes read in 159 ms (8.8 KiB/s)
uboot_overlays: loading /lib/firmware/BB-HDMI-TDA998x-00A0.dtbo ...
4915 bytes read in 161 ms (29.3 KiB/s)
uboot_overlays: loading /lib/firmware/AM335X-PRU-RPROC-4-19-TI-00A0.dtbo ...
3801 bytes read in 358 ms (9.8 KiB/s)
loading /boot/initrd.img-4.19.94-ti-r42 ...
6589689 bytes read in 432 ms (14.5 MiB/s)
debug: [console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait init=/opt/scrip.
debug: [bootz 0x82000000 0x88080000:648cf9 88000000] ...
## Flattened Device Tree blob at 88000000
   Booting using the fdt blob at 0x88000000
   Loading Ramdisk to 8f9b7000, end 8ffffcf9 ... OK
   Loading Device Tree to 8f92b000, end 8f9b6fff ... OK

Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.19.94-ti-r42 (voodoo@x3-am57xx-beagle-x15-2gb) (gcc version 8.3.0 (Debian 8.3.0-6)) #1buster SMP PRE0
[    0.000000] CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] OF: fdt: Machine model: TI AM335x BeagleBone Black
[    0.000000] Memory policy: Data cache writeback
[    0.000000] cma: Reserved 48 MiB at 0x9c800000
[    0.000000] CPU: All CPU(s) started in SVC mode.
[    0.000000] AM335X ES2.1 (sgx neon)
[    0.000000] random: get_random_bytes called from start_kernel+0xac/0x4b4 with crng_init=0
[    0.000000] percpu: Embedded 17 pages/cpu s38988 r8192 d22452 u69632
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 129412
[    0.000000] Kernel command line: console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk1p1 ro rootfstype=eh
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 438412K/522240K available (13312K kernel code, 1136K rwdata, 4308K rodata, 1024K init, 350K bss, 34676K rese)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
[    0.000000]     vmalloc : 0xe0000000 - 0xff800000   ( 504 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xdfe00000   ( 510 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0x(ptrval) - 0x(ptrval)   (14304 kB)
[    0.000000]       .init : 0x(ptrval) - 0x(ptrval)   (1024 kB)
[    0.000000]       .data : 0x(ptrval) - 0x(ptrval)   (1137 kB)
[    0.000000]        .bss : 0x(ptrval) - 0x(ptrval)   ( 351 kB)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] ftrace: allocating 42043 entries in 124 pages
[    0.000000] rcu: Preemptible hierarchical RCU implementation.
[    0.000000] rcu:     RCU restricting CPUs from NR_CPUS=2 to nr_cpu_ids=1.
[    0.000000]  Tasks RCU enabled.
[    0.000000] rcu: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=1
[    0.000000] NR_IRQS: 16, nr_irqs: 16, preallocated irqs: 16
[    0.000000] IRQ: Found an INTC at 0x(ptrval) (revision 5.0) with 128 interrupts
[    0.000000] OMAP clockevent source: timer2 at 24000000 Hz
[    0.000026] sched_clock: 32 bits at 24MHz, resolution 41ns, wraps every 89478484971ns
[    0.000052] clocksource: timer1: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 79635851949 ns
[    0.000068] OMAP clocksource: timer1 at 24000000 Hz
[    0.002180] timer_probe: no matching timers found
[    0.002526] Console: colour dummy device 80x30
[    0.002561] WARNING: Your 'console=ttyO0' has been replaced by 'ttyS0'
[    0.002569] This ensures that you still see kernel messages. Please
[    0.002577] update your kernel commandline.
[    0.002643] Calibrating delay loop... 995.32 BogoMIPS (lpj=1990656)
[    0.021023] pid_max: default: 32768 minimum: 301
[    0.021317] Security Framework initialized
[    0.021339] Yama: becoming mindful.
[    0.021486] AppArmor: AppArmor initialized
[    0.021604] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.021621] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.022714] CPU: Testing write buffer coherency: ok
[    0.022786] CPU0: Spectre v2: using BPIALL workaround
[    0.023277] CPU0: thread -1, cpu 0, socket -1, mpidr 0
[    0.045115] Setting up static identity map for 0x80100000 - 0x80100060
[    0.053022] rcu: Hierarchical SRCU implementation.
[    0.069033] smp: Bringing up secondary CPUs ...
[    0.069064] smp: Brought up 1 node, 1 CPU
[    0.069076] SMP: Total of 1 processors activated (995.32 BogoMIPS).
[    0.069086] CPU: All CPU(s) started in SVC mode.
[    0.070808] devtmpfs: initialized
[    0.105334] VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 3
[    0.105976] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.106007] futex hash table entries: 256 (order: 2, 16384 bytes)
[    0.110001] xor: automatically using best checksumming function   neon      
[    0.110033] pinctrl core: initialized pinctrl subsystem
[    0.111369] NET: Registered protocol family 16
[    0.115822] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.211130] l4_wkup_cm:clk:0010:0: failed to disable
[    0.251380] audit: initializing netlink subsys (disabled)
[    0.257120] audit: type=2000 audit(0.244:1): state=initialized audit_enabled=0 res=1
[    0.260530] OMAP GPIO hardware version 0.1
[    0.285132] hw-breakpoint: debug architecture 0x4 unsupported.
[    0.313178] raid6: using algorithm neonx8 gen() 0 MB/s
[    0.313201] raid6: .... xor() 0 MB/s, rmw enabled
[    0.313211] raid6: using neon recovery algorithm
[    0.321258] edma 49000000.edma: TI EDMA DMA engine driver
[    0.328206] SCSI subsystem initialized
[    0.329500] usbcore: registered new interface driver usbfs
[    0.329569] usbcore: registered new interface driver hub
[    0.329697] usbcore: registered new device driver usb
[    0.331719] omap_i2c 4802a000.i2c: bus 1 rev0.11 at 100 kHz
[    0.333295] omap_i2c 4819c000.i2c: bus 2 rev0.11 at 100 kHz
[    0.333865] pps_core: LinuxPPS API ver. 1 registered
[    0.333880] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    0.333908] PTP clock support registered
[    0.334821] omap-mailbox 480c8000.mailbox: omap mailbox rev 0x400
[    0.337401] Advanced Linux Sound Architecture Driver Initialized.
[    0.338251] NetLabel: Initializing
[    0.338268] NetLabel:  domain hash size = 128
[    0.338276] NetLabel:  protocols = UNLABELED CIPSOv4 CALIPSO
[    0.338371] NetLabel:  unlabeled traffic allowed by default
[    0.339376] clocksource: Switched to clocksource timer1
[    0.501736] VFS: Disk quotas dquot_6.6.0
[    0.501869] VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.502758] AppArmor: AppArmor Filesystem Enabled
[    0.515774] NET: Registered protocol family 2
[    0.516793] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes)
[    0.516836] TCP established hash table entries: 4096 (order: 2, 16384 bytes)
[    0.516883] TCP bind hash table entries: 4096 (order: 3, 32768 bytes)
[    0.516943] TCP: Hash tables configured (established 4096 bind 4096)
[    0.517093] UDP hash table entries: 256 (order: 1, 8192 bytes)
[    0.517120] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[    0.517480] NET: Registered protocol family 1
[    0.530644] RPC: Registered named UNIX socket transport module.
[    0.530667] RPC: Registered udp transport module.
[    0.530675] RPC: Registered tcp transport module.
[    0.530683] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.531747] Unpacking initramfs...
[    0.898869] Freeing initrd memory: 6436K
[    0.899732] hw perfevents: enabled with armv7_cortex_a8 PMU driver, 5 counters available
[    0.902793] Initialise system trusted keyrings
[    0.903229] workingset: timestamp_bits=14 max_order=17 bucket_order=3
[    0.910416] zbud: loaded
[    0.917885] NFS: Registering the id_resolver key type
[    0.917938] Key type id_resolver registered
[    0.917948] Key type id_legacy registered
[    0.917969] nfs4filelayout_init: NFSv4 File Layout Driver Registering...
[    0.918332] fuse init (API version 7.27)
[    0.928957] Key type asymmetric registered
[    0.928982] Asymmetric key parser 'x509' registered
[    0.929090] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 246)
[    0.933467] io scheduler noop registered
[    0.933488] io scheduler deadline registered
[    0.933799] io scheduler cfq registered (default)
[    0.933814] io scheduler mq-deadline registered
[    0.937483] pinctrl-single 44e10800.pinmux: 142 pins, size 568
[    0.950723] gpio-of-helper ocp:cape-universal: ready
[    0.964320] Serial: 8250/16550 driver, 6 ports, IRQ sharing disabled
[    0.968065] 44e09000.serial: ttyS0 at MMIO 0x44e09000 (irq = 30, base_baud = 3000000) is a 8250
[    1.039842] random: fast init done
[    1.725720] console [ttyS0] enabled
[    1.730397] 48022000.serial: ttyS1 at MMIO 0x48022000 (irq = 31, base_baud = 3000000) is a 8250
[    1.740391] 48024000.serial: ttyS2 at MMIO 0x48024000 (irq = 32, base_baud = 3000000) is a 8250
[    1.750275] 481a6000.serial: ttyS3 at MMIO 0x481a6000 (irq = 33, base_baud = 3000000) is a 8250
[    1.760227] 481a8000.serial: ttyS4 at MMIO 0x481a8000 (irq = 34, base_baud = 3000000) is a 8250
[    1.770082] 481aa000.serial: ttyS5 at MMIO 0x481aa000 (irq = 35, base_baud = 3000000) is a 8250
[    1.782496] omap_rng 48310000.rng: Random Number Generator ver. 20
[    1.789164] random: crng init done
[    1.794311] sdhci: Secure Digital Host Controller Interface driver
[    1.800819] sdhci: Copyright(c) Pierre Ossman
[    1.805830] omap_gpio 44e07000.gpio: Could not set line 6 debounce to 200000 microseconds (-22)
[    1.814640] omap_hsmmc 48060000.mmc: Got CD GPIO
[    1.819948] omap_hsmmc 48060000.mmc: Linked as a consumer to regulator.1
[    1.854078] omap_hsmmc 481d8000.mmc: Linked as a consumer to regulator.1
[    1.887256] sdhci-pltfm: SDHCI platform and OF driver helper
[    1.938494] mmc1: new high speed MMC card at address 0001
[    1.949664] mmcblk1: mmc1:0001 MMC04G 3.60 GiB 
[    1.955131] mmcblk1boot0: mmc1:0001 MMC04G partition 1 2.00 MiB
[    1.961909] mmcblk1boot1: mmc1:0001 MMC04G partition 2 2.00 MiB
[    1.968699] mmcblk1rpmb: mmc1:0001 MMC04G partition 3 128 KiB, chardev (245:0)
[    1.981992]  mmcblk1: p1
[    2.026035] eqep 48300180.eqep: ver. 1.0
[    2.030374] eqep 48300180.eqep: count_mode:0
[    2.034732] eqep 48300180.eqep: invert_qa:1
[    2.038964] eqep 48300180.eqep: invert_qb:1
[    2.043199] eqep 48300180.eqep: invert_qi:0
[    2.047429] eqep 48300180.eqep: invert_qs:0
[    2.051654] eqep 48300180.eqep: swap_inputs:0
[    2.056055] eqep 48300180.eqep: QDECCTL:0x0180
[    2.060542] eqep 48300180.eqep: QPOSINIT:0x00000000
[    2.065463] eqep 48300180.eqep: QPOSMAX:0xffffffff
[    2.070299] eqep 48300180.eqep: QPOSCNT:0x00000000
[    2.075135] eqep 48300180.eqep: omit_interrupt:0
[    2.079795] eqep 48300180.eqep: QEINT:0x0800
[    2.084107] eqep 48300180.eqep: QUPRD:0x05f5e100
[    2.088766] eqep 48300180.eqep: QEPCTL:0x009e write
[    2.093780] eqep 48300180.eqep: QEPCTL:0x009e read
[    2.098641] eqep 48300180.eqep: irq:138, clk_rate:100000000
[    2.104516] eqep 48302180.eqep: ver. 1.0
[    2.108651] eqep 48302180.eqep: count_mode:0
[    2.112989] eqep 48302180.eqep: invert_qa:1
[    2.117219] eqep 48302180.eqep: invert_qb:1
[    2.121446] eqep 48302180.eqep: invert_qi:0
[    2.125671] eqep 48302180.eqep: invert_qs:0
[    2.129897] eqep 48302180.eqep: swap_inputs:0
[    2.134296] eqep 48302180.eqep: QDECCTL:0x0180
[    2.138782] eqep 48302180.eqep: QPOSINIT:0x00000000
[    2.143704] eqep 48302180.eqep: QPOSMAX:0xffffffff
[    2.148539] eqep 48302180.eqep: QPOSCNT:0x00000000
[    2.153374] eqep 48302180.eqep: omit_interrupt:0
[    2.158034] eqep 48302180.eqep: QEINT:0x0800
[    2.162345] eqep 48302180.eqep: QUPRD:0x05f5e100
[    2.167005] eqep 48302180.eqep: QEPCTL:0x009e write
[    2.171928] eqep 48302180.eqep: QEPCTL:0x009e read
[    2.176772] eqep 48302180.eqep: irq:140, clk_rate:100000000
[    2.182630] eqep 48304180.eqep: ver. 1.0
[    2.186761] eqep 48304180.eqep: count_mode:0
[    2.191095] eqep 48304180.eqep: invert_qa:1
[    2.195325] eqep 48304180.eqep: invert_qb:1
[    2.199552] eqep 48304180.eqep: invert_qi:0
[    2.203778] eqep 48304180.eqep: invert_qs:0
[    2.208003] eqep 48304180.eqep: swap_inputs:0
[    2.212401] eqep 48304180.eqep: QDECCTL:0x0180
[    2.216886] eqep 48304180.eqep: QPOSINIT:0x00000000
[    2.221807] eqep 48304180.eqep: QPOSMAX:0xffffffff
[    2.226641] eqep 48304180.eqep: QPOSCNT:0x00000000
[    2.231476] eqep 48304180.eqep: omit_interrupt:0
[    2.236143] eqep 48304180.eqep: QEINT:0x0800
[    2.240456] eqep 48304180.eqep: QUPRD:0x05f5e100
[    2.245116] eqep 48304180.eqep: QEPCTL:0x009e write
[    2.250037] eqep 48304180.eqep: QEPCTL:0x009e read
[    2.254885] eqep 48304180.eqep: irq:142, clk_rate:100000000
[    2.305030] libphy: Fixed MDIO Bus: probed
[    2.310293] CAN device driver interface
[    2.315759] c_can_platform 481cc000.can: c_can_platform device registered (regs=b4999130, irq=42)
[    2.325822] c_can_platform 481d0000.can: c_can_platform device registered (regs=7f56f9f7, irq=43)
[    2.391489] davinci_mdio 4a101000.mdio: davinci mdio revision 1.6, bus freq 1000000
[    2.399242] davinci_mdio 4a101000.mdio: detected phy mask fffffffe
[    2.406478] MDIO: davinci_mdio: dt: updated phy_id[0] from phy_mask[fffffffe]
[    2.432248] libphy: 4a101000.mdio: probed
[    2.436511] davinci_mdio 4a101000.mdio: phy[0]: device 4a101000.mdio:00, driver SMSC LAN8710/LAN8720
[    2.447098] cpsw 4a100000.ethernet: Detected MACID = 1c:ba:8c:a2:11:48
[    2.454012] cpsw 4a100000.ethernet: initialized cpsw ale version 1.4
[    2.460511] cpsw 4a100000.ethernet: ALE Table size 1024
[    2.465860] cpsw 4a100000.ethernet: cpts: overflow check period 1250 (jiffies)
[    2.475306] usbcore: registered new interface driver smsc95xx
[    2.482919] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    2.489617] ehci-platform: EHCI generic platform driver
[    2.495309] ehci-omap: OMAP-EHCI Host Controller driver
[    2.501633] usbcore: registered new interface driver usb-storage
[    2.511123] am335x-phy-driver 47401300.usb-phy: 47401300.usb-phy supply vcc not found, using dummy regulator
[    2.521493] am335x-phy-driver 47401300.usb-phy: Linked as a consumer to regulator.0
[    2.532741] am335x-phy-driver 47401b00.usb-phy: 47401b00.usb-phy supply vcc not found, using dummy regulator
[    2.542925] am335x-phy-driver 47401b00.usb-phy: Linked as a consumer to regulator.0
[    2.554078] musb-hdrc musb-hdrc.1: MUSB HDRC host driver
[    2.559561] musb-hdrc musb-hdrc.1: new USB bus registered, assigned bus number 1
[    2.567390] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 4.19
[    2.575725] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.583004] usb usb1: Product: MUSB HDRC host driver
[    2.588014] usb usb1: Manufacturer: Linux 4.19.94-ti-r42 musb-hcd
[    2.594157] usb usb1: SerialNumber: musb-hdrc.1
[    2.599689] hub 1-0:1.0: USB hub found
[    2.603616] hub 1-0:1.0: 1 port detected
[    2.619646] omap_rtc 44e3e000.rtc: registered as rtc0
[    2.626463] i2c /dev entries driver
[    2.634209] omap_wdt: OMAP Watchdog Timer Rev 0x01: initial timeout 60 sec
[    2.641885] softdog: initialized. soft_noboot=0 soft_margin=60 sec soft_panic=0 (nowayout=0)
[    2.654492] ledtrig-cpu: registered to indicate activity on CPUs
[    2.661280] omap-aes 53500000.aes: OMAP AES hw accel rev: 3.2
[    2.667507] omap-aes 53500000.aes: will run requests pump with realtime priority
[    2.677713] omap-sham 53100000.sham: hw accel on OMAP rev 4.3
[    2.687731] hidraw: raw HID events driver (C) Jiri Kosina
[    2.700938] gnss: GNSS driver registered with major 242
[    2.716365] NET: Registered protocol family 10
[    2.790882] Segment Routing with IPv6
[    2.795052] mip6: Mobile IPv6
[    2.798311] NET: Registered protocol family 17
[    2.803475] can: controller area network core (rev 20170425 abi 9)
[    2.809871] NET: Registered protocol family 29
[    2.814466] 8021q: 802.1Q VLAN Support v1.8
[    2.818802] Key type dns_resolver registered
[    2.823176] mpls_gso: MPLS GSO support
[    2.827234] ThumbEE CPU extension supported.
[    2.831625] Registering SWP/SWPB emulation handler
[    2.836473] omap_voltage_late_init: Voltage driver support not added
[    2.844400] registered taskstats version 1
[    2.848598] Loading compiled-in X.509 certificates
[    2.853574] zswap: loaded using pool lzo/zbud
[    2.861258] Btrfs loaded, crc32c=crc32c-generic
[    2.866027] AppArmor: AppArmor sha1 policy hashing enabled
[    3.034297] tda998x 0-0070: found TDA19988
[    3.039417] usb 1-1: new full-speed USB device number 2 using musb-hdrc
[    3.049059] tilcdc 4830e000.lcdc: bound 0-0070 (ops tda998x_ops)
[    3.055234] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    3.061912] [drm] No driver support for vblank timestamp query.
[    3.108507] Console: switching to colour frame buffer device 160x64
[    3.122624] tilcdc 4830e000.lcdc: fb0: DRM emulated frame buffer device
[    3.130141] [drm] Initialized tilcdc 1.0.0 20121205 for 4830e000.lcdc on minor 0
[    3.152024] tps6521x_pwrbutton tps65217-pwrbutton: DMA mask not set
[    3.159237] input: tps65217_pwr_but as /devices/platform/ocp/44e0b000.i2c/i2c-0/0-0024/tps65217-pwrbutton/input/input0
[    3.170986] tps65217 0-0024: TPS65217 ID 0xe version 1.2
[    3.177365] at24 0-0050: 32768 byte 24c256 EEPROM, writable, 1 bytes/write
[    3.184678] omap_i2c 44e0b000.i2c: bus 0 rev0.11 at 400 kHz
[    3.194911] cpu cpu0: Linked as a consumer to regulator.3
[    3.200546] cpu cpu0: Dropping the link to regulator.3
[    3.206347] cpu cpu0: Linked as a consumer to regulator.3
[    3.215030] asoc-simple-card sound: i2s-hifi <-> 48038000.mcasp mapping ok
[    3.224313] omap_rtc 44e3e000.rtc: setting system clock to 2000-01-01 00:00:00 UTC (946684800)
[    3.234613] ALSA device list:
Starting eMMC Flasher from microSD media
Version: [1.20180412: all ssh regneration override...]

Prepare environment for flashing
Starting at Sat Jan  1 00:00:10 UTC 2000
==> Giving system time to stablize...
5 4 3 
2 1 
==> Preparing /tmp
==> Preparing sysctl
==> sysctl: vm.min_free_kbytes=[2648]
==> sysctl: setting: [sysctl -w vm.min_free_kbytes=16384]
vm.min_free_kbytes = 16384
==> Determining root drive
==> console=ttyO0,115200n8 bone_capemgr.uboot_capemgr_enabled=1 root=/dev/mmcblk1p1 ro rootfstype=ext4 rootwait init=/opt/scripts/th
==> root_drive=[/dev/mmcblk1p1]
====> Root drive identified at [/dev/mmcblk1p1]
==> Boot Drive [/dev/mmcblk1p1]
==> Figuring out Source and Destination devices
====> Source identified: [/dev/mmcblk1]
====> Destination identified: [/dev/mmcblk0]
==> Figuring out machine
====> Machine is TI_AM335x_BeagleBone_Black
====> Machine is compatible with BeagleBone Black
5 4 3 2 1 

Checking for Valid bbb-eeprom header
==> Valid bbb-eeprom header found [335]

Checking running system
==> Copying: [/dev/mmcblk1] -> [/dev/mmcblk0]
==> lsblk:
mmcblk1      179:0    0  3.6G  0 disk 
`-mmcblk1p1  179:1    0  3.6G  0 part /
mmcblk1boot0 179:8    0    2M  1 disk 
mmcblk1boot1 179:16   0    2M  1 disk 
==> df -h | grep rootfs:
!==> Error: [/dev/mmcblk0] does not exist
writing to [/dev/mmcblk0] failed...
==> Stopping Cylon LEDs ...
Traceback (last called is first):
     reset_leds() in /opt/scripts/tools/eMMC/functions.sh:433
     write_failure() in /opt/scripts/tools/eMMC/functions.sh:451
     check_running_system() in /opt/scripts/tools/eMMC/functions.sh:614
     main() in /opt/scripts/tools/eMMC/init-eMMC-flasher-v3.sh:47
The command kill $CYLON_PID > /dev/null 2>&1 exited with exit code 2.
Tearing Down script environment
==> Unmounting /tmp
blockdev: cannot open /dev/mmcblk0: No such file or directory
[   24.509191] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100
[   24.509191] 
[   24.519469] CPU: 0 PID: 1 Comm: init-eMMC-flash Not tainted 4.19.94-ti-r42 #1buster
[   24.527156] Hardware name: Generic AM33XX (Flattened Device Tree)
[   24.533324] [<c0113e18>] (unwind_backtrace) from [<c010e388>] (show_stack+0x20/0x24)
[   24.541119] [<c010e388>] (show_stack) from [<c0d20f5c>] (dump_stack+0x8c/0xa0)
[   24.548383] [<c0d20f5c>] (dump_stack) from [<c013c6f0>] (panic+0x10c/0x278)
[   24.555385] [<c013c6f0>] (panic) from [<c01428e4>] (do_exit+0xbf0/0xc08)
[   24.562120] [<c01428e4>] (do_exit) from [<c0142998>] (do_group_exit+0x50/0xd0)
[   24.569377] [<c0142998>] (do_group_exit) from [<c0142a38>] (__wake_up_parent+0x0/0x30)
[   24.577334] [<c0142a38>] (__wake_up_parent) from [<c0101000>] (ret_fast_syscall+0x0/0x54)
[   24.585546] Exception stack(0xdc149fa8 to 0xdc149ff0)
[   24.590623] 9fa0:                   b6f056d8 b6f056d8 00000001 00000000 5b74bb00 00000001
[   24.598839] 9fc0: b6f056d8 b6f056d8 00000000 000000f8 00000001 00000000 b6f0a140 b6f07000
[   24.607054] 9fe0: 000000f8 be9f8b64 b6e86389 b6e28746
[   24.612152] ---[ end Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100
[   24.612152]  ]---
==> Stopping Cylon LEDs ...
==> Setting LEDs to