Intel AX210 on Ai-64

Has anyone tested AX210 6E wifi?

It shows up with lspci : 01:00.0 Network Controller: Intel Corporation Device 2725 (rev 1a)

Seems it isn’t supported in Debian 11 with Kernel 5.10.x and may need a backported kernel. What are the consequences of moving to 5.14.x?

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=989777

2 Likes

Do you have a model number for that WiFi chipset? Or an Amazon order link, and I’ll take a look at it…

1 Like

PXL_20220809_021758834~2

1 Like

this one works well.

image

Looks like I need to try out some AX210 models, not just AX200.

We may want to start a works/non-works list…

I’ve got a few models already…

We can start something here, and either @lorforlinux or merge requests can add something to Documentation / docs.beagleboard.io · GitLab. Eventually, the content on that page will be posted to https://docs.beagleboard.org and the BeagleBone AI-64 SRM will be hosted there.

1 Like

AX210 needs at least 5.11 kernel to make it run without backporting.

I am confused by this post. Did this device work with BBAI=64 or not. The post below by Stat_headcrabed implies that it doesnt. Has anyone made an AX210 work?

It does NOT with the current kernel. There is a post above referencing the AX200 working but not the AX210.

This chip-set is being picky… 5.10.x with backport of intel 5.11.x driver, even with sid’s firmware… still no go…

debian@BeagleBone:~$ lspci
00:00.0 PCI bridge: Texas Instruments Device b00d
01:00.0 Network controller: Intel Corporation Device 2725 (rev 1a)
debian@BeagleBone:~$ dmesg | grep iw
[    8.445947] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[    8.574328] iwlwifi 0000:01:00.0: api flags index 2 larger than supported by driver
[    8.574396] iwlwifi 0000:01:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 93.8.63.28
[    8.575920] iwlwifi 0000:01:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[    8.741513] iwlwifi 0000:01:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[    8.907847] iwlwifi 0000:01:00.0: loaded PNVM version 0xd35929d8
[    9.009837] iwlwifi 0000:01:00.0: Timeout waiting for PNVM load!
[    9.015859] iwlwifi 0000:01:00.0: Failed to start RT ucode: -110
[    9.021882] iwlwifi 0000:01:00.0: iwl_trans_send_cmd bad state = 1
[    9.233859] iwlwifi 0000:01:00.0: firmware didn't ACK the reset - continue anyway
[    9.253850] iwlwifi 0000:01:00.0: Failed to run INIT ucode: -110

Regards,

“Another simple workaround is to remove/rename /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm file.”

https://bugzilla.kernel.org/show_bug.cgi?id=212371

I’ve seen this suggested in a few different places, could you try that?

Nice find!

root@BeagleBone:~# lspci
00:00.0 PCI bridge: Texas Instruments Device b00d
01:00.0 Network controller: Intel Corporation Device 2725 (rev 1a)
root@BeagleBone:~# dmesg | grep iw
[    8.448016] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[    8.518127] iwlwifi 0000:01:00.0: api flags index 2 larger than supported by driver
[    8.518199] iwlwifi 0000:01:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 93.8.63.28
[    8.519641] iwlwifi 0000:01:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[    8.675216] iwlwifi 0000:01:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[    8.894506] iwlwifi 0000:01:00.0: base HW address: 08:8e:90:10:36:69
root@BeagleBone:~# ifconfig -a
SoftAp0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 08:8e:90:10:36:6a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.3.106  netmask 255.255.252.0  broadcast 192.168.3.255
        inet6 fe80::2676:25ff:fea1:273  prefixlen 64  scopeid 0x20<link>
        ether 24:76:25:a1:02:73  txqueuelen 1000  (Ethernet)
        RX packets 213  bytes 36521 (35.6 KiB)
        RX errors 0  dropped 13  overruns 0  frame 0
        TX packets 60  bytes 8138 (7.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 97  bytes 9265 (9.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 97  bytes 9265 (9.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 1e:90:52:61:0e:e1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether aa:8d:80:1a:57:c0  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 08:8e:90:10:36:69  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
1 Like

Great! Will the backported driver be included in future daily builds?

I’ve got it staged right now in git:

i just need to reflash my image from all my hacks and then figure out what to do with that firmware file…

Regards,

1 Like

FYI, I saw this when I was looking for a fix before…

“It appears that periodic updates to the package linux-firmware will install a new version of the offending file iwlwifi-ty-a0-gf-a0.pnvm and so this process will need to be repeated.”

Exactly, i’m worried about that… At some point mainline (6.0.x and older) might need that file… SO i’d like to just disable it in our 5.10.x tree…

Edit: okay i just disabled pnvm loading for iwlwifi devices:

tested on both AX200 and AX210 are there any other related iwlwifi devices i should look at?

My goal is to give everyone a v6.0.x option in the next few weeks, (it boots, working on mainline submition), so just removing the firmware files won’t be a good long term solution.

Edit 2: now tagged and being built, upgrade will be available in a few hours…

Regards,

Okay, it’s out:

debian@BeagleBone:~$ uname -r
5.10.120-ti-arm64-r60

Just running:

sudo apt update
sudo apt upgrade
sudo reboot

Will get you the new kernel…

Regards,