Is the bbb_debian, images search reporting 32-bit systems for aarch64?


I am probably out-of-line here but I tried to update the BBAI-64 w/ Bookworm and Bullseye images from this forum. I seem to be having issues, i.e. nothing new to me. I have always had issues…

Anyway, my board keeps booting into initramfs.

I tried 1 - 3 w/ the UART0 and all fail into initramfs. Is this on purpose or is the image 32-bit instead of 64-bit (both Bullseye and Bookworm)?

The reason, my main reason for asking here, I am looking for help here is that I wanted to try to help me and help others w/ my findings…

Outside of that idea, I have not built anything in some time. I am floating right now doing nothing.

Please let me know if I need to show all three, different output items of the 1 - 3 options...


P.S. I know this is a lot to take on for a small group of individuals and I am aware of differences in opinion on group matters. Anyway, live on and help me! Ha. I hope someone can provide some input on the issues…

I mean…


I got busybox and .so files for use but nothing is sticking over reboots or power downs…

Has anyone else had similar issues?

Another Update

Okay…so I bricked the board somehow. This is what I did:

initramfs: blkdiscard /dev/mmcblk*

Now, nothing works. Do NOT do this to your board…

So, w/out further analysis, is there a way to unbrick the BBAI-64 after commanding it to remove the partitions?


Light it up with debug port attached to your host and post that.

Also what image started the problems?

FYI, use gtkterm and have it send everything to a log file. Turn that on before booting so you can see everything.

Good timing,

Notta. I get nothing. I started w/ Bookworm and then Bullseye.


P.S. The UART0 debug header serves no purpose b/c the LEDs no longer show signs of life nor does the debug port on tio /dev/ttyUSB0.

Even the power light is out?

everything but…

The PWR LED lives on!

You should be able to recover it.
Are you seeing any thing on debug port?

No, nothing on the debug port is showing up. I waited for an hour. Nothing.

No odd symbols or hexadecimal notation.


Maybe it is dead. You would see something immediately when powered up. Have you looked at the TI docs for the SoC to see how to start it up?

One of our ai64 died on the shelf, it was working, I am the one that powered it down. Went back a few months later and it is dead, no led. So, that has me a little suspicious…

1 Like

I have not looked at the TI docs.

Just grab the minimal flasher snapshot: ARM64 - Debian 11.x (Bullseye) - Monthly Snapshots - 2023-10-07

Use to flash a mciroSD.

Then insert microSD into bbai64, insert power, hold ‘user’, toggle ‘reset’ buttons…

Watch it flash over USART0


1 Like

I will try and return service once complete.

Okay. You are right.

I booted some random image…

I commanded it this way…

1. Install SD Card w/ random image
2. Hold down the "boot" button
3. Toggle the "reset" button

Thank you! It boots!


One last question on this subject matter before I reboot or boot again…

Will I need the UART0 TTL to USB cable adapter to handle booting each time?


The serial to USB adapter is not required for normal operation.

1 Like

Okay…so the toggle business is what to do no matter what in regards to the USB adapter and/or just USB-Ethernet connections. Okay.

I will test this later and return service just in case it is or is not the case.

Okay and Okay Again,

Sorry here but…

  1. USB to TTL converter cable works
  2. I cannot get the board booted w/ ssh access w/out the USB to TTL cable
  3. The board boots, it shows on my desktop as an icon, and the ssh access is denied each time

Is this something new w/ Debian Bookworm WSL2 instance?

The reason I think it is b/c of WSL2 changing hands over time w/ specific drivers is the fact that I read over this forum in posts about the lack there of specific NDIS drivers not being available on current images/kernels.

Anyway, hearsay or whatever, I am missing something…

Send rations of ideas pretty please!


I tried:

ssh debian@
ssh debian@MY_IP_ADDRESS
ssh debian@beaglebone.local

I also tried:

ssh beagle@
ssh beagle@MY_IP_ADDRESS
ssh beagle@beagleone.local

WSL with Windows 10 or Windows 11?


Windows 11 on WSL2/5.15.133

It seems the system is refusing ssh connections now…

I can try PuTTY if necessary.

which flasher file did you flash?